Pour les besoins d’un cours, j’ai dû installer une version plus vieille que celle actuellement disponible sur les dépôts (3.4.2-1).

Pour cela, il faut tout d’abord préparer l’environnement nécessaire pour l’interface graphique IDLE développée en Tk, en installant les paquets suivants :

sudo apt-get install python3-tk tk-dev

Ensuite, il suffit d’aller télécharger l’archive officielle de cette version à l’adresse suivante :

http://www.python.org/ftp/python/3.3.5/Python-3.3.5.tgz

Décompressez-là dans un dossier approprié (typiquement dans /tmp/ ), puis une fois dans le dossier décompressé, lancer les deux commandes suivantes :

./configure --prefix=/opt/python3.3.5
make && sudo make install

Et voilà ! Il ne vous reste plus qu’à lancer le bon IDLE qui se trouve dans le dossier /opt/python3.3.5/bin .

Sources :

http://fr.wikipedia.org/wiki/Tk_%28informatique%29 (pour plus d’infos sur l’interface graphique)

http://ziadrahhal.com/2012/02/configure-python-for-tk/ (concernant les paquets nécessaires à l’interface graphique)

http://askubuntu.com/a/244550 (pour l’installation en tant que telle)

Advertisements