Cette erreur peut par exemple apparaître dans un terminal en essayant de lire un DVD avec mplayer ou vlc à partir d’un terminal.

Elle vient du fait que le DVD est encripté et nécessite pour être lu une bibliothèque (libdvdcss2) qui n’est pas dans les dépôts officiels. Il est donc nécessaire de rajouter le dépôt « Debian Multimedia » dans la liste des dépôts consultés.Avant toute chose, il faut installer le trousseau de clés du dépôt :

sudo apt-get install deb-multimedia-keyring

Ensuite, on peut rajouter le-dit dépôt aux sources. Par exemple en mode manuel, il faut ajouter la ligne suivante au fichier /etc/apt/sources.list :

deb http://www.deb-multimedia.org testing main non-free

(attention à la nouvelle URL depuis le 10 mai 2012 !)

Ensuite, un classique

sudo apt-get dist update

suivi d’un

sudo apt-get dist install libdvdcss2

devraient faire l’affaire.

Bons films !

Sources :

http://forums.debian.net/viewtopic.php?f=6&t=66989#p383166 (pour le paquet à installer)

http://deb-multimedia.org/ (pour le changement de nom du dépôt et le trousseau de clés à installer préalablement)

Advertisements